Garage door opener problem. Page 1 / 2

gunhand, Mar 14, 4:43pm
Have had a garage door opener for about 4 years (was installed before we bought house) and had no issues with it. However over last few months its failed to open with remote (no option on unit itself). If you tried in morning it wouldnt work but in afternoon it would or vice versa. Turning power off and back on seemed to remedy issue for a while as did blowing it out (ie cleaning) as they get dusty. But this weekend it won't do anything. Ive got two remotes and both flash their lights when button pushed. There is a red light on unit as well and its on. Ariel seems in place.
I did open unit and it says, "no serviceable parts"
So, is it fried and time for a new one? or could I try contact cleaner?
Brand is Merlin.

saxman99, Mar 14, 4:55pm
A few years ago I had an older Merlin which behaved as you describe. The fix was to open the non serviceable relays and clean the contacts. Possibly worth a look if yours has unsealed relays.

gunhand, Mar 14, 4:58pm
Thanks, yea bloody annoying. Thankfully the other unit works fine (double garage) but its a different brand. I will try that.

tigertim20, Mar 14, 5:16pm
merlin are crap.

you can get replacement units (depending on door type) from bunnings and mitre10 who both carry some.
also garadoor etc. or try a commercial door specialist, theyll have motors suitable as well, and theyll be good quality ones

gunhand, Mar 14, 5:20pm
Unit on other door is a Garador unit and it seems fine. Lot newer looking than the merlin.

intrade, Mar 14, 6:34pm

gunhand, Mar 14, 6:42pm
Well there is a circuit board in it with circuity board things all over it.

trade4us2, Mar 14, 6:56pm
My Dominator garage door opener has worked fine for 30 years. Buy a decent brand! The guy selling another major brand said that it was impossible to install an opener on my garage. He was wrong!

kiwicarol, Mar 14, 7:03pm
Have you tried replacing the battery in the remote?

gunhand, Mar 14, 7:06pm
Yes, replaced a relatively new one, just in case. Tried that first time it happened.

lilyfield, Mar 14, 8:15pm
Open, spray with electrical CRC 2/26, good forever after.

gunhand, Mar 14, 8:21pm
Is this the same as contact cleaner?

gunhand, Mar 14, 9:03pm
Cool, I have some of that.

evotime, Mar 14, 11:38pm
I have an old one in my new place which wasn’t working turns out the manual switch by the side door has two positions (rather than spring loaded) in one position the remote is disabled you don’t have something similar do you?
Edit: I forget what brand mine is

rovercitroen, Mar 15, 1:29pm
We had one at a previous house that would intermittently not work. You could turn the power to it off and on and that would fix it for a day or week or month. Sent the circuit board away and got it fixed and then it was good for a year or two. Eventually replaced it with a new one with a belt instead of a chain. So much quieter and it had soft open and close. I can't remember the brands sorry.

neville48, Mar 15, 4:24pm
our one works till the door is not quite open then stops and you have to close it again then open it which sometimes it does properly. mostly not, then it goes fine for a wee time but you come out in the morning and the door is open. or half open. or just not closed or ? you get my drift, pain in the butt. The overide switch has never worked anyway.

realtrader1, Mar 15, 5:41pm
Perhaps your newish battery is not well enough charged. Try brand new and clean the contacts too.

gunhand, Mar 15, 5:50pm
I replaced the newish battery with a new one. and neither of the two remotes are opening it even though their lights are working when pushed. But I will try another new battery cause you just never know.
Ive sprayed it with contact cleaner and nothing yet.

lookoutas, Mar 19, 7:32pm
Mine went into opening mode when the power came back on, if there'd been a power cut. Lucky it first happened during the day when someone was home, and not when we were away for the weekend.
Fitted one of those things that I was told to get which would trip and kill the power if it went off, but it was a pain in the butt having to re-program the door every time there was a power cut, and the only place I could fit this gizmo was above the car, so switching it back on wasn't easy.
Perfectly looking door opener waiting to be thrown in the tip now. Can't put up with that carry-on for too long.

trade4us2, Mar 19, 8:34pm
My Dominator opener can be reset by turning the power off for a while. Let's say 10 minutes. Then allow the door to go down to the ground and back up. It then remembers that setting.

gunhand, Mar 19, 8:40pm
I spoke with Dominator who reckon the motor/unit is toast. Mind you they asked what kind of remote I had and I said its a Such in such shape ( kinda ovilish with big round button) and they said, you sure its not a rectangle shape? Bloody hell Ive only used it for four years.
But they were happy to price a new unit of course.
How does one test it I wonder. hasn't worked at all now all week.

tigertim20, Mar 19, 9:27pm
gunny, call Total Door Services in Dunedin. Tell Mike you were sent to him by Tim. They sub to me often and he can most likely see you right

geoff_m, Mar 19, 9:29pm
You can get after market remotes if it is a remote problem.
Does it still open and close off the wall button?
For our 40 you Merlin, you can't get the remotes any more, so I got a $30 remote activated relay from aliexpress.com and a 12v power supply and wired that into the push button circuit. I am sure the garage door people in nz sell something similar.

gunhand, Mar 19, 9:37pm
Cheers, thing is I can replace the whole unit for not much more than it would cost for someone to tell me its poked. And with a new one I get a 5 year warranty.

gunhand, Mar 19, 9:39pm
Does not appear to be remote issue, no wall unit and no button on unit to open it but can detach the chain drive and lift manually. I got no history on unit so could be old as the hills anyway, certainly don't look at all modern.

Share this thread

Buy me a coffee :)Buy me a coffee :)